English
网站导航
 
 


 
  : 咨询热线
 考试咨询  培训咨询  MSN咨询

公司地址:深圳市罗湖区


服务列表

课程列表
培训课程介绍
红帽redhat
CISCO思科认证
Aruba认证课程
IPV6课程
CWNP无线认证
H3C认证
Oracle认证
企业实战培训
CIW网络认证

>>>>>进入技术文摘 列表
 

SecureCRT的自动登录和自动脚本记录功能图解(原创)


点击进入:技术文摘  专栏  添加时间: 2010-4-30 17:02:14  阅读数: 13176
 
 

SecureCRT的自动登录和自动脚本记录功能图解(原创)

                                                                                                              作者:周老师

 

一.实现自动登陆

SecureCRT 的自动登陆是在它的 会话选项—登陆动作—自动登陆 下设置的

1 192.168.10.1的会话上点右键,选择属性

 3 选择登陆登陆动作选项卡,对自动登陆多选框打√

 

4选中login password分别编辑

 

预期username 是路由器准备给你发来的登陆提示

telnet 192.168.10.1为例,登陆使用Username + Password认证

当路由器发送预期字符“Username: ”时,CRT自动发送用户名“apple”给路由器

当路由器发送预期字符“Password:”时,CRT自动发送密码“12345678”给路由器

User Access Verification

Username: apple  

Password: 12345678 

Cwnpchina#

 

 

5 编辑好后点确定,关闭会话选项

 

6 连接测试,现在连接192.168.10.1就不用手工输入账号密码了

 

 

二.脚本录制及自动初始化配置路由器

在使用dynamipsGNS3做网络实验的时候,每次路由器初始化配置一些基本功能

在网络中大规模部署网络设备的时候,也会遇到大量设备要做很多相同的配置的时候

这些配置虽然简单但是数量很大,会浪费掉很多宝贵的时间,

如果使用SceureCRT功能强大的脚本功能,就可以化繁为简,

使做实验和工程达到事半功倍的效果!

 

SecureCRT自动配置设备是通过脚本文件来实现的,

脚本可以录制,也可以手工编写 这里的脚本使用的是.vbs格式的

1 脚本的录制

 

单击“开始录制脚本”后,在路由器中输入的任何命令都会当成脚本里的命令记录下来,我们在这里为路由器R1做一个初始化配置的脚本,现在输入其配置命令如下:

en

conf t

line con 0

logging sync

exec-time 0 0

end

conf t

hostname R1

interface s1/1

ip address 12.1.1.1 255.255.255.0

no shutdown

interface s1/2

encapsulation frame-relay

no shutdown

interface f0/0

ip address dhcp

no shutdown

interface loopback 0

ip address 10.10.10.10 255.255.255.0

no shutdown

line vty 0 4

logging sync

exec-time 0 0

password cisco

login

end

conf t

2 停止录制脚本,后保存为R1.vbs 拓展名是.vbs

 

打开脚本可以看到其内容,通过修改脚本就很快制作出其他路由器的配置脚本

crt.Screen.Synchronous = True

 

' This automatically generated script may need to be

' edited in order to work correctly.

 

Sub Main

         crt.Screen.Send "en" & chr(13)

         crt.Screen.Send "conf t" & chr(13)

         crt.Screen.Send "line con 0" & chr(13)

         crt.Screen.Send "logging sync" & chr(13)

         crt.Screen.Send "exec-time 0 0" & chr(13)

         crt.Screen.WaitForString "R1(config-line)#"

         crt.Screen.Send "end" & chr(13)

         crt.Screen.Send "conf t" & chr(13)

         crt.Screen.Send chr(13)

         crt.Screen.Send "hostname R1" & chr(13)

         crt.Screen.WaitForString "R1#"

         crt.Screen.Send chr(13)

         crt.Screen.Send "interface s1/1" & chr(13)

         crt.Screen.WaitForString "R1(config)#"

         crt.Screen.Send "ip address 12.1.1.1 255.255.255.0" & chr(13)

         crt.Screen.Send "no shutdown" & chr(13)

         crt.Screen.WaitForString "R1(config-if)#ip address"

         crt.Screen.Send chr(13)

         crt.Screen.Send "interface s1/2" & chr(13)

         crt.Screen.Send "encapsulation frame-relay" & chr(13)

         crt.Screen.WaitForString "R1(config-if)#no shu"

         crt.Screen.Send "no shutdown" & chr(13)

         crt.Screen.Send chr(13)

         crt.Screen.WaitForString "R1(config-if)#no "

         crt.Screen.Send "interface f0/0" & chr(13)

         crt.Screen.Send "ip address dhcp" & chr(13)

         crt.Screen.WaitForString "R1(config-if)#"

         crt.Screen.Send "no shutdown" & chr(13)

         crt.Screen.Send chr(13)

         crt.Screen.Send "interface loopback 0" & chr(13)

         crt.Screen.Send "ip address 10.10.10.10 255.255.255.0" & chr(13)

         crt.Screen.Send "no shutdown" & chr(13)

         crt.Screen.Send chr(13)

         crt.Screen.Send "line vty 0 4 " & chr(13)

         crt.Screen.Send "logging sync" & chr(13)

         crt.Screen.Send "exec-time 0 0" & chr(13)

         crt.Screen.Send "password cisco" & chr(13)

         crt.Screen.Send "login" & chr(13)

         crt.Screen.Send "end" & chr(13)

         crt.Screen.Send "conf t"

End Sub

3 使用制作好的脚本文件的两种方法

1)手工运行配置脚本文件:

 

 

 

然后选择已经做好的脚本文件,这里给R3做配置选R3.vbs

 

执行的效果是SecureCRT自动为R3路由器做了初如化配置:

 

  

2)设备启动自动加载脚本运行,依旧是登陆动作选项卡,如图配置即可

 

 

  三.保存配置日志

secureCRT 的日志保存是通过虚拟打印机来实现的

1虚拟打印机配置 全局选项—终端—打印

 

2配置虚拟打印机及指定纸张参数 当然选默认配置也可以

 

3打印当前屏幕

保存文件名为R3log.xps文档

 

 

 

之后就可以双击打开该文档看到CRT上刚才屏幕上的内容已经被记录下来了:

 

4 自动打印——实现日志记录功能

开始选择自动打印—选择打印文档存储的位置

之后屏幕上所有的输入输出都会被记录下来!

 

我们打下自动打印后 在路由器R3上配置好RIP,开debug 看下输出

R3>en

R3#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R3(config)#router rip

R3(config-router)#ver 2

R3(config-router)#no auto

R3(config-router)#net 30.0.0.0

R3(config-router)#net 23.0.0.0

R3(config-router)#end

R3#debug ip rip

 

这是屏幕输出,缺点是一闪而过,没法保存下来仔细分析

 

 下面是打印机保存的文档,可以把输出永久保存!

 
合作伙伴
             
地址:广东省深圳市罗湖区宝安南路2014号振业大厦A座15A-B(地王大厦旁) Email:kevinzhu#cntimes.biz(将#改为@)
电话:0755-25022500 25025151 传真:0755-25022400  ICP备案:粤ICP备14017173号 网站优化方案